Как настроить iptv на роутере через wi-fi

Unicast

Тип передачи данных Unicast (индивидуальный) используется для обычной
передачи данных от хоста к хосту. Способ Unicast работает в
клиент-серверных и пиринговых (peer-to-peer, от равного к равному)
сетях.

В unicast пакетах в качестве IP адреса назначения используется
конкретный IP адрес устройства, для которого этот пакет предназначен.
IP адрес конкретного устройства состоит из порции адреса сети (в которой
находится это устройство) и порции адреса хоста (порции, определяющей
это конкретное устойчиво в его сети). Это все приводит к возможности
маршрутизации unicast пакетов по всей сети.

Multicast и broadcast пакеты, в отличие от unicast пакетов, имеют свои
собственные специальные (зарезервированные) IP адреса для использования
их в заголовке пакетов в качестве пункта назначения. Из-за этого,
broadcast пакеты в основном ограничены пределами локальной сети.
Multicast трафик также может быть ограничен границами локальной сети, но
с другой стороны также может и маршрутизироваться между сетями.

В IP сетях unicast адрес является адресом, то есть адресом конечного
устройства (например, компьютера). Для типа передачи данных unicast,
адреса хостов назначаются двум конечным устройствам и используются (эти
адреса) как IP адрес источника и IP адрес получателя.

В течение процесса инкапсуляции передающий хост размещает свой IP адрес в
заголовок unicast пакета в виде адреса источника, а ИП адрес
принимающего хоста размещается в заголовке в виде адреса получателя.
Используя эти два IP адреса, пакеты unicast могут передаваться через всю
сеть (т.е. через все подсети).

Мультикастовые MAC-адреса

Так какие же MAC-адреса получателей подставляются в заголовок Ethernet таких пакетов? Широковещательные? Нет. Существует специальный диапазон MAC-адресов, в которые отображаются мультикастовые IP-адреса.

Эти специальные адреса начинаются так: 0x01005e и следующий 25-й бит должен быть 0 (попробуйте ответить, почему так). Остальные 23 бита (напомню, всего их в МАС-адресе 48) переносятся из IP-адреса.

Здесь кроется некоторая не очень серьёзная, но проблема. Диапазон мультикастовых адресов определяется маской 224.0.0.0/4, это означает, что первые 4 бита зарезервированы: 1110, а оставшиеся 28 бит могут меняться. То есть у нас 2^28 мультикастовых IP-адресов и только 2^23 MAC-адресов — для отображения 1 в 1 не хватает 5 бит. Поэтому берутся просто последние 23 бита IP-адреса и один в один переносятся в MAC-адрес, остальные 5 отбрасываются.

Multicast MAC Address

Фактически это означает, что в один мультикастовый MAC-адрес будет отображаться 2^5=32 IP-адреса. Например, группы 224.0.0.1, 224.128.0.1, 225.0.0.1 и так до 239.128.0.1 все будут отображаться в один MAC-адрес 0100:5e00:0001.

Если взять в пример дамп потокового видео, то можно увидеть:

Дамп мультикаста

IP адрес — 224.2.2.4, MAC-адрес: 01:00:5E:02:02:04.

Есть также другие мультикастовые MAC-адреса, которые никак не относятся к IPv4-мультикаст (). Все они, кстати, характеризуются тем, что последний бит первого октета равен 1.

Естественно, ни на одной сетевой карте, не может быть настроен такой MAC-адрес, поэтому он никогда не будет в поле Source MAC Ethernet-кадра и никогда не попадёт в таблицу MAC-адресов. Значит такие кадры должны рассылаться как любой Unknown Unicast во все порты VLAN’а.

Всего, что мы рассматривали прежде, вполне достаточно для полноценной передачи любого мультикастового трафика от потокового видео до биржевых котировок. Но неужели мы в своём почти совершенном мире будем мирится с таким безобразием, как широковещательная передача того, что можно было бы передать избранным?

Вовсе нет. Специально для перфекционистов придуман механизм IGMP Snooping.

Querier

Рассмотрим чуть более сложный случай:

В клиентский сегмент подключено два (или больше) маршрутизатора, которые могут вещать трафик. Если ничего не сделать, мультикастовый трафик будет дублироваться — оба маршрутизатора ведь будут получать Report от клиентов. Во избежание этого существует механизм выбора Querier — опрашивателя. Тот кто победит, будет посылать Query, мониторить Report и реагировать на Leave, ну и, соответственно, он будет отправлять и трафик в сегмент. Проигравший же будет только слушать Report и держать руку на пульсе.

Выборы происходят довольно просто и интуитивно понятно.

Рассмотрим ситуацию с момента включения маршрутизаторов R1 и R2.

  1. Активировали IGMP на интерфейсах.
  2. Сначала по умолчанию каждый из них считает себя Querier.
  3. Каждый отправляет IGMP General Query в сеть. Главная цель — узнать, есть ли клиенты, а параллельно — заявить другим маршрутизаторам в сегменте, если они есть, о своём желании участвовать в выборах.
  4. General Query получают все устройства в сегменте, в том числе и другие IGMP-маршрутизаторы.
  5. Получив такое сообщение от соседа, каждый маршрутизатор оценивает, кто достойнее.
  6. Побеждает маршрутизатор с меньшим IP (указан в поле Source IP пакета IGMP Query). Он становится Querier, все другие — Non-Querier.
  7. Non-Querier запускает таймер, который обнуляется каждый раз, как приходит Query с меньшим IP-адресом. Если до истечения таймера (больше 100 секунд: 105-107) маршрутизатор не получит Query с меньшим адресом, он объявляет себя Querier и берёт на себя все соответствующие функции.
  8. Если Querier получает Query с меньшим адресом, он складывает с себя эти обязанности. Querier’ом становится другой маршрутизатор, у которого IP меньше.

Тот редкий случай, когда меряются, у кого меньше.

Ещё пара слов о других версиях IGMP

Версия 1 отличается по сути только тем, что в ней нет сообщения Leave. Если клиент не хочет больше получать трафик данной группы, он просто перестаёт посылать Report в ответ на Query. Когда не останется ни одного клиента, маршрутизатор по таймауту перестанет слать трафик.

Во-вторых, что более важно, IGMPv3 стал поддерживать SSM в чистом виде. Это так называемый Source Specific Multicast

В этом случае клиент может не просто запросить группу, но также указать список источников, от которых он хотел бы получать трафик или наоборот не хотел бы. В IGMPv2 клиент просто запрашивает и получает трафик группы, не заботясь об источнике.

Содержимое IGMP Membership Report в IGMPv3

Итак, IGMP предназначен для взаимодействия клиентов и маршрутизатора. Поэтому, возвращаясь к Примеру 2, где нет маршрутизатора, мы можем авторитетно заявить — IGMP там — не более, чем формальность. Маршрутизатора нет, и клиенту не у кого запрашивать мультикастовый поток. А заработает видео по той простой причине, что поток и так льётся от коммутатора — надо только подхватить его.

Напомним, что IGMP не работает для IPv6. Там существует протокол MLD.

Приручаем multicast +7

  • 07.11.18 01:53


catersplay

#429062

Хабрахабр

2600

Системное администрирование, Сетевые технологии, Блог компании ICL Services

Остановимся на анализе мультикаст-трафика через IGMP-протокол. Рассмотрим реализацию работы протокола IGMP, работы протокола PIM, отправки JOIN-запросов. После анализа проблемы была разработана оптимальная конфигурация сетевого оборудования, эффективная настройка QOS. Данная задача появилась после обнаружения проблемы в сети, такой как прерывание сигнала у клиентов, наличие фризов и прерывание звука. IGMP — Internet Group Management Protocol — это сетевой протокол взаимодействия абонентов мультикаст-трафика и ближайшего к ним сетевого оборудования.
Пользователь имеет подписку на следующую группу IP-адресов: 224.0.0.0 до 239.255.255.255. PIM Protocol реализован в режиме Sparse mode. Это означает, что трафик льется только на ту ветку, в которой есть клиенты, желающие войти в мультикаст-группу. Они отправляют сообщения PIM Join. Если клиенты не отправляют Join, то трафик им отправляться не будет. PIM Sparse Mode включен на двух интерфейсах. В сторону источника мультикаст-трафика и в сторону клиента

На стороне клиента имеет цифровой ресивер или абонентское устройство —IPTV-приставка.
Для справки: dense mode предполагает, что мультикаст-трафик идет до абонента, и неважно, подписывается ли он на определенный канал. Мультикаст идет во все порты, потом, если он не нужен по месту назначения, то отправляется служебный пакет PIM Prune, и трафик перестает идти по этой ветке

IGMP-протокол реализуется в сторону клиента. PIM-протокол устанавливает соседство с другими маршрутизаторами. Для этого применяются служебные сообщения PIM Hello.
В нашей сети применялась вторая версия протокола IGMP.
Абонентское устройство, которое решает получить multicast-трафик, отправляет запрос в сообщении IGMP Membership Report (так называемый репорт).
Если абонентское устройство больше не желает получать мультикаст-трафик, то оно отправляет сообщение IGMP Leave. Эта функция реализована коммутаторах уровня доступа. IGMP Membership Group-Specific Query — повторное сообщение коммутатором в сеть о том, есть ли клиентские устройства, которые будут запрашивать мультикаст-трафик. Если их нет, то передача трафика прекращается.
IGMP snooping реализуется на сетевом оборудовании, отдельного включения функции недостаточно, необходима дополнительная настройка. После включения данной функции управляемые коммутаторы могут анализировать трафик — мультикаст-поток.
Если коммутатор обнаруживает IGMP-пакет, то он вносит порт в список мультикаст-групп. Если от абонента идет сообщение IGMP Leave, то коммутатор удаляет порт из подписчиков групп.
IGMP snooping позволяет предотвращать мультикаст шторм. Если функция IGMP snooping не включена, то оборудование ретранслирует multicast-трафик во все порты, которые находятся в одном VLAN. Это не эффективно, а также способно вызвать проблемы на сетевых устройствах, вынужденных обрабатывать высокий поток данных. Это может загружать CPU-оборудования. IGMP snooping улучшает работу сети.
Однако для того, чтобы получить мультикаст-трафик, нужно реализовать эту функции на стороне клиента. К примеру, если клиент подключен через роутер, то необходимо позаботиться о включении этой функции на роутере.
Проверить корректность работы мультикаст-вещания можно путем анализа трафика через Wireshark, после включения телевидения через VLC-медиаплеер. В настройках VLC указываем, к примеру, udp:@239.255.0.A:5500. Для передачи потока используется UDP протокол, далее идет мультикаст адрес, далее порт.
При разработке QOS учитывалось, что «красить» трафик желательно ближе к ядру сети. Его необходимо красить ближе к Randezvous Point. (Ну это для нашего случая)
На коммутаторах уровня доступа у нас применялись следующие настройки:
Глубокий анализ проблемы, применение средств диагностики и понимание работы протокола IGMP позволяет выработать эффективную и оптимальную конфигурацию мультикаст-трафика в вашей сети.

Broadcast (Широковещание)

Из-за того, что тип передачи broadcast используется для отправки пакетов ко всем хостам в сети, пакеты использую специальный broadcast IP адрес. Когда хост получает пакет, в заголовке которого в качестве адреса получателя указан broadcast адрес, он обрабатывает пакет так, как будто это unicast пакет.

Когда хосту необходимо передать какую-то информацию всем хостам в сети используется способ передачи данных broadcast. Еще когда адрес специальных сервисов (служб) или устройств заранее неизвестен, то для обнаружения также используется broadcast (широковещание).

Примеры, когда используется broadcast передача данных:

  • создание карты принадлежности адресов верхнего уровня к нижним (например, какой IP адрес на конкретном устройстве со своим MAC адресом)
  • запрос адреса (в качестве примера можно взять протокол ARP)
  • протоколы маршрутизации обмениваются информацией о маршрутах (RIP, EIGRP, OSPF)

Когда хосту нужна информация, он отправляет запрос на широковещательный адрес. Все остальные хосты в сети получат и обработают этот запрос. Один или несколько хостов вложат запрашиваемую информацию и ответят на запрос. В качестве типа передачи данных, отвечающие на запрос будут использовать unicast.

Подобным образом, когда хосту необходимо отправить информацию всем хостам в сети, он создаёт широковещательный пакет с его информацией и передаёт его в сеть.

В отличие от unicast передачи, где пакеты могут быть маршрутизированы через всю сеть, broadcast пакеты, как правило, ограничиваются локальной сетью. Это ограничение зависит от настройки маршрутизатора, который ограничивает сеть и следит за типом широковещания (broadcast).

Существует два типа broadcast передачи данных: направленное широковещание и ограниченное широковещание.

Направленный broadcast (направленное широковещание)

Направленный broadcast отправляется всем хостам какой-то конкретной сети. Этот тип широковещания удобно использовать для отправки broadcast трафика всем хостам за пределами локальной сети.

Например, хост хочет отправить пакет всем хостам в сети 172.16.5.0/24, но сам хост находится в другой сети. В данном случае хост-отправитель вложит в заголовок пакета в качестве адреса пункта назначения broadcast адрес 172.16.5.255. Хотя маршрутизаторы должны ограничивать (не передавать) направленный широковещательный трафик, их можно настроить на разрешение передачи broadcast трафика.

Ограниченный broadcast (ограниченное широковещание)

Ограниченный broadcast используется для передачи данных всем хостам в локальной сети. В такие пакеты в качестве пункта назначения вставляется IP адрес 255.255.255.255. Маршрутизаторы такой широковещательный трафик не передают. Пакеты, переданные ограниченным broadcast будут распространяться только в локальной сети. По этой причине локальные сети IP также называют широковещательным доменом (broadcast domain). Маршрутизаторы образуют границу для широковещательного домена. Без границы пакеты бы распространялись по всей сети, каждому хосту, уменьшая быстродействие сетевых устройств и забивая пропускную способность каналов связи.

Приведу пример ограниченного broadcast: хост находится внутри сети 172.16.5.0/24 и хочет передать пакет всем хостам в его сети. Используя в качестве пункта назначения IP адрес 255.255.255.255, он отправляет широковещательный пакет. Этот пакет примут и обработают все хосты только в этой локальной сети (172.16.5.0/24).

Обработка BUM в VxLAN

Использование VXLAN в качестве оверлейной технологии позволяет предоставлять услуги связи на уровне звена данных между конечными точками, которые могут быть развернуты в сетевых доменах сетевого уровня . Поскольку эти конечные точки логически являются частью одного и того же домена канального уровня, они должны быть способны отправлять и принимать кадры с множеством адресатов канального уровня (трафик BUM). Трафик BUM можно обменивать через границы сети сетевого уровня, инкапсулируя его в пакеты VXLAN, адресованные группе многоадресной рассылки, чтобы использовать сеть для служб репликации трафика.

В обучении на уровне данных широковещательный трафик перенаправляется членам группы многоадресной рассылки. В Control Plane Learning адреса собираются и пересылаются через BGP . Широковещательный трафик подавляется, и VTEP отвечает вызывающему абоненту напрямую.

VxLAN может обрабатывать BUM двумя способами: многоадресная рассылка и репликация головного узла .

Многоадресная рассылка является наиболее распространенной, и каждый VNI ( сетевой идентификатор VxLAN ) сопоставляется с одной группой многоадресной рассылки, в то время как каждая группа многоадресной рассылки может отображаться на один или несколько VNI. Когда VTEP оживает, он использует протокол IGMP для присоединения к группам многоадресной рассылки для используемых им VNI. Когда VTEP должен отправить трафик BUM, он отправит его только в соответствующую группу многоадресной рассылки. Это метод обнаружения VTEP.

Репликация головного узла доступна только при использовании BGP EVPN. Он менее эффективен, чем многоадресная рассылка, и плохо масштабируется, но его проще реализовать, если у вас нет инфраструктуры с поддержкой многоадресной рассылки. В Host End Replication, когда приходит сообщение об ошибке, VTEP создает несколько одноадресных пакетов и отправляет по одному каждому VTEP, который поддерживает VNI.

Выбираем правильный роутер для IPTV

Напомним, что роутер работает с IPTV только через мультикаст, а значит, нам нужен такой роутер, который бы поддерживал данную функцию. Она называется IGMP. Если возникло желании подключить ресивер для цифрового ТВ, эта функция называется STB, необходимо это учесть заранее, так как к маршрутизаторам, которые работают с IPTV через UDP-to-HTTP, подключить ресивер нет возможности. Думаю, не будет лишнем предоставить топ-десятку лучших маршрутизаторов с поддержкой IPTV:

  • TP-LINK TL-WR841N – средняя цена по стране всего 1300 рублей, бюджетный вариант.
  • MikroTik hAP lite – средняя цена чуть выше, 1600, но он очень качественный и многофункциональный.
  • Xiaomi Mi WiFi Router 3 – известнейшая китайская компания с большим выбором цифровой электроники, средняя цена 2400.
  • ASUS RT-AC51U – средняя цена по России 2400.

IPv6

Общий формат адреса многоадресной рассылки (старый)
Биты 8 4 4 112
Поле префикс флаги объем ID группы
Общий формат адреса многоадресной рассылки (новый)
Биты 8 4 4 4 4 8 64 32
Поле префикс ff1 объем ff2 зарезервированный пленка сетевой префикс ID группы

Префикс имеет значение и далее для всех адресов многоадресной рассылки.

В настоящее время определены 3 из 4 битов флагов в поле флагов ( ff1 ); старший бит флага зарезервирован для использования в будущем. Остальные три флага известен как R , P и T .

Флаги многоадресного адреса
Немного Флаг 1
0 (MSB) Зарезервированный (Зарезервированный) (Зарезервированный)
1 R (Свидание) Точка рандеву не встроена Точка рандеву встроена
2 P (префикс) Без префиксной информации Адрес на основе префикса сети
3 (младший бит) T (переходный) Хорошо известный многоадресный адрес Динамически назначаемый многоадресный адрес

Подобно одноадресному адресу, префикс многоадресного IPv6-адреса определяет его область действия, однако набор возможных областей для многоадресного адреса отличается. 4-битное поле sc (или область видимости) (биты с 12 по 15) используется для указания, где адрес действителен и уникален.

Область многоадресной рассылки
IPv6-адрес Эквивалент IPv4 Объем Цель
ff00 :: / 16, ff0f :: / 16 Зарезервированный
ffx1 :: / 16 127.0.0.0/8 Интерфейс-локальный Пакеты с этим адресом назначения не могут быть отправлены ни по одному сетевому каналу, но должны оставаться в пределах текущего узла; это многоадресный эквивалент одноадресного адреса обратной связи .
ffx2 :: / 16 224.0.0.0/24 Link-local Пакеты с таким адресом назначения никуда не маршрутизируются.
ffx3 :: / 16 239.255.0.0/16 Локальная область IPv4
ffx4 :: / 16 Админ-локальный Наименьшая область, которая должна быть настроена администратором.
ffx5 :: / 16 Локальный сайт Только в локальной физической сети.
ffx8 :: / 16 239.192.0.0/14 Организация-местная Только для сетей, используемых организацией, управляющей локальной сетью. (Например, эти адреса могут использоваться через VPN ; когда пакеты для этой группы маршрутизируются через общедоступный Интернет (где эти адреса недействительны), они должны быть инкапсулированы в какой-то другой протокол.)
ffxe :: / 16 224.0.1.0-238.255.255.255 Глобальный охват Подходит для маршрутизации через общедоступный Интернет.

Услуга указывается в поле идентификатора группы . Например, если ff02 :: 101 относится ко всем серверам протокола сетевого времени (NTP) в сегменте локальной сети, то ff08 :: 101 относится ко всем серверам NTP в сетях организации. Поле идентификатора группы может быть для специальных типов адресов многоадресной передачи.

Известные адреса многоадресной рассылки IPv6

В следующей таблице представлен список известных многоадресных IPv6-адресов, зарегистрированных в IANA.

Адрес Описание
ff02 :: 1 Все узлы в сегменте локальной сети
ff02 :: 2 Все роутеры в сегменте локальной сети
ff02 :: 5 OSPFv3 Все маршрутизаторы SPF
ff02 :: 6 OSPFv3 Все маршрутизаторы DR
ff02 :: 8 IS-IS для маршрутизаторов IPv6
ff02 :: 9 RIP роутеры
ff02 :: a Маршрутизаторы
EIGRP
ff02 :: d PIM роутеры
ff02 :: 16
ff02 :: 1: 2
ff02 :: 1: 3
ff05 :: 1: 3
ff0x :: c
ff0x :: fb
ff0x :: 101 Сетевой протокол времени
ff0x :: 108 Сетевая информационная служба
ff0x :: 181 Сообщения протокола точного времени (PTP) версии 2 (Sync, Announce и т. Д.), Кроме измерения задержки однорангового узла
ff02 :: 6b Протокол точного времени (PTP) версии 2 сообщения измерения задержки однорангового узла
ff0x :: 114 Используется для экспериментов

MBGP

Протокол MBGP — это основной метод переноса двух наборов маршрутов: один набор для одноадресной маршрутизации и второй — для мультиадресной. MBGP предоставляет средства управления, которые определяют, куда может быть направлен поток мультиадресных пакетов. PIM использует маршруты, связанные с мультиадресной маршрутизацией, для создания деревьев распространения данных. MBGP обеспечивает путь RPF, а не создание состояния «multicast». Однако PIM необходим для пересылки мультиадресных пакетов.

Конфигурация маршрутизатора A

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.2.2 255.255.255.0 


interface serial0 
ip address 192.168.100.1 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.1 255.255.255.0 


router bgp 123 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.1.1 remote-as 321 nlri unicast multicast 
neighbor 192.168.1.1 ebgp-multihop 255 
neighbor 192.168.100.2 update-source loopback0 
neighbor 192.168.1.1 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.1 


route-map setNH permit 20 

Конфигурация маршрутизатора B

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.1.1 255.255.255.0 


interface serial0 
ip address 192.168.100.2 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.2 255.255.255.0 


router bgp 321 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.2.2 remote-as 123 nlri unicast multicast 
neighbor 192.168.2.2 ebgp-multihop 255 
neighbor 192.168.100.1 update-source loopback0 
neighbor 192.168.2.2 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.2 


route-map set NH permit 20

Если одноадресная и мультиадресная топологии совмещаются (например, проходят через один и тот же канал), основное различие их конфигурации заключается в команде nlri unicast multicast. Пример приводится ниже:

Совмещающиеся топологии с MBGP имеют преимущество, несмотря на то, что трафик проходит через один путь, к одноадресному и мультиадресному потокам BGP можно применить разные политики.

Дополнительные сведения о MBGP см. в документе Что такое MBGP?.

Активация функции IGMP snooping

Функция отслеживания и анализа трафика доступна на управляемых сетевых коммутаторах или свичах. Это устройство помогает реализовывать принципы группового вещания на канальном уровне сети. Для активации IGMP snooping требуется вручную включить и настроить её на коммутаторе. Неуправляемые аналоги не поддерживают режим анализа трафика, так как не могут быть настроены через интерфейс.

Перед использованием коммуникатора в вашей сети убедитесь, что конечный получатель (например, smart-tv) поддерживает режим snooping. Обычно устройства имеют соответствующий пункт в разделе «Настройка сетевого подключения», что заметно упрощает регулировку мультивещания.

Рассмотрим способ подключения функции через командную строку на примере популярных коммутаторов D-Link:

  1. Откройте командную строку устройства с помощью CLI-интерфейса.
  2. Введите «enable-igmp-snooping». Эта команда включит функцию на коммутаторе и всех подключенных адресах.
  3. Введите «config-igmp-snooping-vlan-default-state-enable», что позволит настроить протокол в VLAN.
  4. Команда «confog-multicast-vlan-filtering-mode-vlan-default-filter-unregistred-groups» включает на коммуникаторе фильтрацию данных с нескольких адресов сразу.
  5. В завершение используйте «config-igmp-snooping-vlan-default-fast-leave-enable» в сети VLAN.

Последняя команда включает функцию IGMP Snooping Fast Leave, которая исключает порт из сети, как только пользователь сделал запрос «leave». Благодаря Fast Leave, потребитель не получит ненужные данные и не будет их обрабатывать. Это уменьшит нагрузку на сеть и позволит коммутатору работать более эффективно.

Настройка роутера для IPTV

Действия по настройке сильно отличаются в зависимости от производителя устройства. Чтобы не запутаться в панели, предлагаем рассмотреть инструкции для самых популярных роутеров.

Как подключить IPTV к телевизору через роутер TP-Link

  1. В меню маршрутизатора переходим в раздел «Сеть» на страницу «IPTV».
  2. Включаем IGMP Proxy.
  3. В строке «Режим» устанавливаем параметр в положение «Мост».
  4. Задаем LAN-порт для связи со Smart TV (подойдет только 3 и 4).                                                                             
  5. Сохраняем настройки.
  6. Подключаем телевизор с портом на роутере.

Если некоторые параметры отсутствуют, скорее всего маршрутизатор не поддерживает IPTV. Это общая инструкция, которая подходит для большинства провайдеров, но не для всех. В отдельных случаях нужно обращаться за помощью в техподдержку провайдера.

Инструкция для Asus

  1. Открываем параметры управления роутером.
  2. Идем в раздел «ЛВС» в графу «Маршрут» и включаем «Активация многоадресной маршрутизации».           
  3. Переходим в подраздел WAN, на вкладку «Интернет соединение».
  4. Устанавливаем выделенный порт для IPTV.
  5. Сохраняем изменения.

Принцип настройки на роутерах D-link

  1. Переходим в раздел «Advanced», а затем – в «Advanced-Network».
  2. Устанавливаем флажок напротив «Enable multicast streams».                                                                                       
  3. Активируем UPnP.
  4. Применяем внесенные изменения.

Для роутеров от Zyxel

В устройствах Zyxel многое зависит от модели. К примеру, в NBG-334-WEE и NBG-460-NEE, нужно дополнительно активировать «Enable IGMP Snooping Multicast», а в Keenetic есть специальная вкладка «IP-телевидение» в разделе «Домашняя сеть».

Это краткое изложение основополагающей информации о технологии IPTV в роутерах, которой достаточно для формирования представления о системе и ее использовании. Функция действительно полезна, удобна и может стать более функциональной заменой обычному телевидению, поэтому рекомендуем ей пользоваться.

Настройка IP-TV на маршрутизаторах

В качестве примера были разобраны настройки на таких маршрутизаторах, как D-link, Asus, ZyXEL, TP-Link. Для других производителей и моделей последовательность действий практически идентичная и не сильно изменяется.

Роутеры модели D-Link

Наиболее часто приобретаемой моделью D-link является роутер D-link Dir 615 и настройка для этого производителя будет разобрана из его веб-интерфейса. Кстати, для его конфигурирования нужно выполнить всего два действия:

  1. Перейти в конфигуратор роутера и найти там вкладку Дополнительно (Advanced);
  2. Выбрать пункт Дополнительно сеть (Advanced Network) и включить опцию Enable multicast streams.

Более редкие модели DIR-320 NRU и DIR-300 NRU настраиваются так:

  1. Переход в конфигуратор и поиск вкладки «Сеть» — «WAN»;
  2. Поиск параметра IGMP и его включение;
  3. Сделать шаг назад и перейти в «Сеть» — «Соединения» — «l2tp_eth2.2_0»;
  4. Установить галочку напротив пункта «Keep Alive» и установить интервалы = 30, а провалы = 5;
  5. Указать маршрут статического типа во вкладке «Дополнительно»

Важно! На этом настройка мультикаста для роутеров производителя D-link завершается. Как видно, она не требует огромного количества действий и знания всех тонкостей работы системы маршрутизатора

Роутеры модели Asus

Устройства компании Асус отличаются тем, что их настройка может происходить по двум сценариям. Наиболее частый выглядит так:

  1. Переход в конфигуратор и найти вкладку Локальная вычислительная сеть вифи — «Маршрут»;
  2. Подтвердить включение многоадресной маршрутизации и сохранить изменения, нажав на «Применить».

Этот способ простой и легкий, так как нет нужды возиться с дополнительными параметрами и программами: всю работу на себя берет прибор. Такое подключение выполняется только при наличии кабеля типа Ethernet. Если использовать этот конфигуратор на других сетевых устройствах локальной вычислительной сети, то скорость будет значительно ниже, с просадками.

Роутеры модели ZyXEL

На примере роутера ZyXEL Keenetic Start конфигурирование осуществляется следующим образом:

  1. Переход в конфигуратор и поиск пункта «WAN», в котором располагается текстовое поле выбора портов моста;
  2. Указание того Лан порта, в который в последствии будет подключена телевизионная приставка;
  3. Если это возможно, выбрать количество подключаемых портов в соответствующем поле «Choose IPTVSTB PORT».

Важно! Продукты от ZyXEL должны быть прошиты самой последней версией программного обеспечения. Если это условие не выполнено, то iptv Wifi может не заработать даже после настроек

Роутеры модели TP-Link

Маршрутизаторы этого производителя также нуждаются последней прошивке. Их преимущество над Зухел состоит в том, что после установки ПО последней версии роутер сам подключает Мультикаст и занимается его настройкой. Если ТВ не запускается, то, возможно, причина в старом плейлисте или проигрывателе старой и неподдерживаемой версии, неправильном подключении проводов. Возможна и блокировка контента со стороны антивируса или провайдера.

Настройка роутера для iptv TP-link не отличается сложностью исполнения

Оцените статью
Рейтинг автора
5
Материал подготовил
Андрей Измаилов
Наш эксперт
Написано статей
116
Добавить комментарий