Для начинающих:настройка dhcp-сервера

DHCP Options

Sub-menu:

With the help of DHCP Option list, it is possible to define additional custom options for DHCP Server to advertise. Option precedence is as follows:

  • radius,
  • lease,
  • server,
  • network.

According to the DHCP protocol, a parameter is returned to the DHCP client only if it requests this parameter, specifying the respective code in DHCP request Parameter-List (code 55) attribute. If the code is not included in Parameter-List attribute, the DHCP server will not send it to the DHCP client.

Properties

Property Description
code (integer:1..254; Default: )
name (string; Default: ) Descriptive name of the option
value (string; Default: ) Parameter’s value.

Starting from v6.8 available data types for options are:

  • 0xXXXX — hex string (works also in v5)
  • ‘XXXXX’ — string (works also in v5 but without ‘ ‘ around the text)
  • $(XXXXX) — variable (currently there are no variables for server)
  • ‘10.10.10.10’ — IP address
  • s’10.10.10.10′ — IP address converted to string
  • ’10’ — decimal number
  • s’10’ — decimal number converted to string

RouterOS has predefined variables that can be used:

  • HOSTNAME — client hostname
  • RADIUS_MT_STR1 — from radius MT attr nr. 24
  • RADIUS_MT_STR2 — from radius MT attr nr. 25
  • REMOTE_ID — agent remote id
  • NETWORK_GATEWAY — first gateway from ‘/ip dhcp-server network’, note that this option won’t work if used from lease

Now it is also possible to combine data types into one, for example:
«0x01’vards’$(HOSTNAME)»

For example if HOSTNAME is ‘kvm’, then raw value will be 0x0176617264736b766d.

raw-value (HEX string ) Read only field which shows raw dhcp option value (the format actually sent out)

Example

Classless Route

A classless route adds specified route in clients routing table. In our example, it will add

  • dst-address=160.0.0.0/24 gateway=10.1.101.1
  • dst-address=0.0.0.0/0 gateway=10.1.101.1

According to RFC 3442: The first part is the netmask («18» = netmask /24). Second part is
significant part of destination network («A00000» = 160.0.0). Third part is IP address of
gateway («0A016501» = 10.1.101.1). Then There are parts of the default route, destination netmask (0x00 = 0.0.0.0/0) followed by default route (0x0A016501 = 10.1.101.1)

/ip dhcp-server option
add code=121 name=classless value=0x18A000000A016501000A016501
/ip dhcp-server network
set 0 dhcp-option=classless

Result:

 /ip route> print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf,
m - mme, B - blackhole, U - unreachable, P - prohibit
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          10.1.101.1         0
 1 ADS  160.0.0.0/24                       10.1.101.1         0

Much more robust way would be to use built in variables, previous example can be rewritten as:

/ip dhcp-server option 
add name=classless code=121 value="0x18A00000\$(NETWORK_GATEWAY)0x00\$(NETWORK_GATEWAY)"

Auto Proxy Config

/ip dhcp-server option 
  add code=252 name=auto-proxy-config value="'http://autoconfig.something.lv/wpad.dat'"

Настройка WAN интерфейса MikroTik

Изменение MAC адреса WAN порта

Если Ваш провайдер блокирует доступ к сети по MAC адресу, то необходимо сначала изменить MAC адрес WAN порта роутера MikroTik. В противном случае пропустите этот пункт.

для подключения к командной строке маршрутизатора буду использовать telnet клиент. В работе необходимо учитывать, что все данные по telnet протоколу передаются в открытом виде. Открываем в Windows командную строку и вводим следующую команду:

telnet 192.168.88.1

Пользователь, под которым мы будем заходить на сетевое устройство — admin; пароль — пустой.

Чтобы изменить MAC адрес порта MikroTik, открываем в программе Winbox меню New Terminal и вводим команду:

/interface ethernet set ether1 mac-address=a1:b2:c3:d4:e5:f6

где ether1 – имя WAN интерфейса, a1:b2:c3:d4:e5:f6 — MAC адрес, разрешенный на стороне провайдера.

Чтобы вернуть родной MAC адрес порта, нужно выполнить команду:

/interface ethernet reset-mac-address ether1

где ether1 – имя интерфейса.

Настройка Dynamic IP

Если интернет провайдер выдает Вам сетевые настройки автоматически, то необходимо настроить WAN порт роутера MikroTik на получение настроек по DHCP:

  1. Открываем меню IP
  2. Выбираем DHCP Client
  3. В появившемся окне нажимаем кнопку Add (синий плюс)
  4. В новом окне в списке Interface: выбираем WAN интерфейс ether1
  5. Нажимаем кнопку OK для сохранения настроек

Проверяем какой IPv4 адрес мы получили от провайдера (видим в столбце IP Address). В вашем случае может быть IPv6, конечно если вы включили в Микротике поддержку IP протокола 6 версии.

Есть ли связность с глобальной сетью Интернет?

С помощью командной строки проверяем доступность сервера Google DNS — в терминале вводим команду ping 8.8.8.8

.
Пинги проходят достаточно быстро round–trip time, RTT составляет 2ms, что очень неплохо (цифры реальные). Сеть Интернет доступна и работает отлично. По умолчанию команда будет слать пакеты без ограничений. После отправки 3-х пакетов понятно, что связность есть, остановил выполнение команды нажатием Ctrl+C.

Без настройки локальной сети и преобразования сетевых адресов NAT на маршрутизаторе MikroTik на клиентских компьютерах Интернет работать не будет.

Настройка статического IPv4 адреса на внешнем интерфейсе

В корпоративных сетях провайдеры обычно предлагают настраивать оборудование вручную, с помощью статических сетевых настроек. Пропишем настройки на внешнем WAN интерфейсе маршрутизатора вручную.

Настроим статический IP адрес и маску подсети внешнего интерфейса:

  1. Слева выбираем меню IP
  2. Переходим на строку Addresses
  3. В новом окне добавим новый адрес (синий плюс)
  4. В появившемся окне в поле Address: прописываем статический IP адрес / маску подсети;
  5. В списке Interface: выбираем WAN интерфейс ether1;
  6. Для сохранения настроек нажимаем кнопку OK.

Настоим адрес интернет шлюза MikroTik:

  1. Слева выбираем в меню IP
  2. Переходим на строку Routes;
  3. В новом окне добавим новый адрес (синий плюс)
  4. В появившемся в поле Gateway: прописываем IP адрес шлюза
  5. Нажимаем кнопку OK для сохранения настроек

Добавим адреса DNS серверов MikroTik:

  1. Слева выбираем в меню IP
  2. Переходим на строку DNS
  3. В появившемся окне заполняем поле Servers: выбрал Google DNS IPv4 8.8.8.8
  4. Нажимаем кнопку “вниз” (черный треугольник), чтобы добавить еще одно поле для ввода
  5. В новом поле добавляю IP адрес запасного  DNS сервера Google 8.8.4.4
  6. Разрешаем обработку удаленных запросов Allow Remote Requests (позже необходимо будет закрыть доступ к DNS серверу для внешних клиентов)
  7. Сохраняем настройки — нажимаем OK.

Открываем Terminal, чтобы проверить доступ к глобальной паутине по доменным именам

С помощью командной строки проверяем доступность WEB сервера, на котором расположен данный сайт 14bytes.ru — в терминале вводим команду ping 14bytes.ru

Пинги до WEB сервера доходят и возвращаются. Скорость оборота пакетов оставляет желать лучшего round–trip time, RTT составляет 40ms. Далековато я нахожусь от сервера. DNS преобразование имени в IP адрес вопросов не вызывает; сеть Интернет работает отлично. По умолчанию команда будет слать пакеты без ограничений. После отправки 5-ти пакетов понятно, что связность есть, остановил выполнение команды нажатием Ctrl+C.

Без настройки локальной сети и преобразования сетевых адресов NAT на маршрутизаторе MikroTik на клиентских компьютерах Интернет работать не будет.

Настройка RB3011UiAS-RM

Для стандартной настройки RB 3011 необходимо выполнить следующую последовательность действий:

  1. Включить микротик в электрическую сеть;
  2. Подключиться к порту RJ-45 (в любой порт, кроме Eth1);
  3. Зайти в утилиту Winbox;
  4. Подключиться по MAC-адресу или IP- адресу;
  5. Согласиться на загрузку стандартной конфигурации;
  6. При желании, можно изменить параметры настройки сети на свои.

В стандартной конфигурации роль WAN порта исполняет порт Eth1. Также при использовании стандартной настройки, предоставляется достаточно оптимальная конфигурация Firewall, работающая по принципу «запрещено всё, кроме того, что разрешено».

Если используется 2 провайдера и появилась необходимо настраивать резервирование каналов:

  1. Требуется подключить 2 канала в соответствующие интерфейсы;
  2. Произвести соответствующие маркировки в Mangle;
  3. Задать правила маршрутизации.

источник

DHCP + MAC

Некоторые поставщики интернета могут закрывать доступ к сети через МАС адрес. В таких случаях требуется изменить МАС адреса используемого WAN порта.

Делается это просто:

  1. в главном меню Winbox находим пункт NewTerminal;
  2. набираем команду: interface ethernet set ether1 mac-address=00:01:02:03:04:05.

Cтатический IP

Для некоторых провайдеров нужен статический (другими словами постоянный) ip-адрес.

Чтобы задать его таковым образом, делаем следующее:

в главном меню выбираем пункт AddNew. В результате появится окно с заданием основных параметров для нового статического адреса;

ip-адрес и маска сети – прописываем те значения, которые были выданы провайдером;

затем нужно будет выбрать используемый порт (в нашем случае это ether 1);

На этом все. Если при вводе какого-либо параметра цифры стали подсвечиваться красным, значит значения некорректны.

Проверка соединения

Чтобы удостовериться в активности соединения, кликаем на NewTerminal. В появившемся окне набираем «pinggoogle.ru» (вместо ya.ru можно указать любой другой сайт). Если будут показываться какие-либо значения пинга (он будет зависеть от скорости интернета), значит соединение установлено.

Локальная сеть

С помощью этого роутера можно создать локальную сеть, причем не только проводную, но и Wi-Fi.

Вначале нужно создать мост:

  1. заходим в раздел Bridge;
  2. кликаем по кнопке Add;

В появившемся поле нужно будет ввести какое-либо имя моста.

Чтобы добавить в созданное объединение проводные порты, делаем следующее:

  1. открываем раздел Ports и щелкаем по иконке Add;
  2. в разделе интерфейсов выбираем ether 2;


В разделе bridge созданное имя моста.

Включение маскарадинга локальной сети

В некоторых ситуациях может потребоваться активация маскарадинга.

Производится она так:

  • в главном меню выбираем Ip, далее Firewall;
  • появится список, в котором выбираем пункт NAT;
  • кликаем по пункту создания нового правила (NewRule);
  • во вкладке General в пункте Chain выбираем scrchat, а в OutInterface выставляем WAN1;
  • заходим во вкладку Action и в ней выбираем Masquerade

WIFI на роутере

Безусловно, главное предназначение этого устройства – создание Wi-Fi подключения. Создается оно в несколько простых шагов:

  • заходим в меню Wireless, в нем кликаем по иконке wlan1;
  • выбираем режим Enable (включено);
  • затем заходим во вкладку Security Profiles;
  • в ней щелкаем по кнопке Add (плюсик красного цвета);
  • в появившемся окне вводим имя нового профиля, а также пароль;
  • также нужно будет выбрать метод шифрования. Лучше отдать предпочтение WPA2 PSK;
  • далее заходим в пункт Interfaces;
  • двойным щелчком по wlan1 открываем его настройки (нам нужна вкладка Wireless);
  • в поле modeостанавливаем выбор на режиме apbridge;
  • band – B/G/B;
  • SSID – выбираем имя нашей точки доступа. При этом нельзя пользоваться русскими буквами и спецсимволами;
  • в конце выбираем созданный ранее профиль безопасности и нажимаем ок.

Заливка новой прошивки и Reset конфигурации

В некоторых случаях может потребоваться произвести обновление прошивки (для некоторых провайдеров это обязательное требование). Производится данная процедура следующим образом:

скачиваем последнюю версию с официального сайта Mikrotic и сохраняем файл прошивки в удобном месте;

в главном меню Winbox заходим во вкладку File;
откроется окно поиска, в котором нужно будет найти тот самый файл с прошивкой

Обратите внимание, что у него должно быть расширение .npk;
перетаскиваем с помощью мыши этот файл в окно FileList;

спустя некоторое время прошивка загрузится. Если все прошло без проблем, новый файл появится во вкладке FileList;
в конце нужно будет перезагрузить (выключить и включить) роутер.

Бывают ситуации, когда обновление прошивки привело к критическим или фатальным ошибкам. В таких ситуациях есть простой выход – сбросить настройки к заводским. Для этого нужно нажать кнопочку Reset(лучше с помощью ручки) и подержать в течение 10-15 секунд.

Настройка подключения к провайдеру по DHCP

Всё больше провайдеров отдают настройки своим клиентам сразу по DHCP, это просто и удобно как для провайдера, так и для клиентов, минимум настройки со стороны клиента и возможность для провайдера выдавать не только IP адреса а и многие другие параметры. Заходим IP>DHCP Client > + Interface = WAN1, остальные настройки можно оставить стандартные. Use peer DNS — означает использование провайдерских DNS, NTP — синхронизация времени, Add Default Route — добавлять ли стандартный маршрут в таблицу маршрутизации и Default Route Distance — приоритет маршрута по сравнению с другими, если у Вас несколько провайдеров то изменяя приоритет можно управлять предпочитаемым маршрутом для трафика, 0 — самый высокий приоритет. 

Или тоже самое в консоли:

/ip dhcp-client add interface=WAN1 disabled=no

Как попасть в настройки?

Типовым IP-адресом Wi-Fi роутеров MikroTik является 192.168.88.1. Для открытия веб-интерфейса по данному IP нужно будет вписать его в адресную строку браузера и нажать Enter.

В открывшемся интерфейсе есть возможность задать различные параметры и воспользоваться разделом статистики, где графически отражена работа устройства.

Для дальнейшей работы можно воспользоваться следующими версиями настройки устройства:

  • утилитой Winbox;
  • браузерной административной панелью;
  • Telnet.

Чтобы не ограничивать себя спектром настроек подключения, выбираем первый пункт. Скачиваем специальное приложение для Windows, в котором указываем возможные параметры функциональности роутера. Данную программу при необходимости скачивают также на сайте производителя по адресу https://MikroTik.com/download. Winbox работает без установки на компьютер.

Для настройки Wi-Fi следует:

  1. Открыть Winbox.
  2. Перейти на вкладку Neighbors. Спустя какое-то время программой будет найден маршрутизатор.
  3. У роутеров MikroTik по умолчанию графа Password для ввода остается пустой (можно задать свой пароль), а Login – admin.
  4. Кликнуть по опции Connect.

Открыв следующее окно, выберите либо сохранение, либо удаление стандартных настроек устройства. Если необходимо произвести настройку сначала, нажмите Remove, а для сохранения заводских параметров – ОК.

Для этого нужно придерживаться такой последовательности выполнения процедуры:

  • Заходим в меню System – Users.
  • Выбираем из выпавшего списка Group для предоставления административных полномочий full.
  • Вводим новый пароль.
  • Удаляем из списка учетных записей стандартный административный аккаунт, нажав строку admin.
  • Завершаем процесс нажатием кнопки «-» в верхнем меню.

В будущем подключиться к маршрутизатору и войти в настройки уже нельзя будет без введения пароля. Если вы его забудете, то придется вернуться к настройкам производителя.

После успешного завершения подключения к маршрутизатору необходимо воспользоваться вкладкой Interface и открыть Wireless, после чего нажать на опцию с галочкой и выбрать точку, которая называется Wlan1. Произведенные действия активируют процесс беспроводного интерфейса устройства.

Затем нужно проследовать на Security profiles и нажать на главный профиль default. В открывшемся окне нужно будет произвести замену на default keys вкладки Mode. Следующим действием будет пометка галочками полей WPA2 PSK и WPA PSK и aes ccm. Теперь только нужно будет задать пароль Wi-Fi в полях безопасности беспроводной сети и сохранить настройки.

Подключение к провайдеру по L2TP/PPTP

Честно говоря я не припоминаю чтоб хотя бы раз настраивал такое подключение, но в некоторых странах этот тип подключений по прежнему остается широко распространенным, поэтому рассмотрим и его. Оба типа подключения требуют предварительной настройки IP-адреса и возможно прописывания маршрутов, подробности обычно можно узнать на сайте провайдера или в его поддержке. Предполагается что с этим вы разобрались и настроили статический или динамический IP-адрес по инструкции выше, а так же узнали логин, пароль и адрес VPN сервера для подключения.
Настройка аналогична PPPoE:
Добавляем интерфейс PPTP/L2TP: PPP > + > PPTP Client или L2TP Client смотря что у Вас, на вкладке General укажите имя подключения (например ISP1), а на вкладке Dial out нужно указать адрес сервера, логин, пароль, в Profile выбрать Default, поставить галку Add default route и выставить Distance = 1

Изменять/заполнять нужно только выделенные поля

Команды для консоли:

Для pptp-client:/interface pptp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

Для l2tp заменить pptp-client на :/interface l2tp-client add name=ISP1 disabled=no connect-to=Адрес сервера user=Логин password=Пароль add-default-route=yes default-route-distance=1 profile=default

Properties

Sub-menu:

Property Description
add-default-route (yes | no | special-classless; Default: yes) Whether to install default route in routing table received from dhcp server. By default RouterOS client complies to RFC and ignores option 3 if classless option 121 is received. To force client not to ignore option 3 set special-classless. This parameter is available in v6rc12+
  • yes — adds classless route if received, if not then add default route (old behavior)
  • special-classless — adds both classless route if received and default route (MS style)
client-id (string; Default: ) Corresponds to the settings suggested by the network administrator or ISP. If not specified, client’s MAC address will be sent
comment (string; Default: ) Short description of the client
default-route-distance (integer:0..255; Default: ) Distance of default route. Applicable if is set to .
disabled (yes | no; Default: yes)
host-name (string; Default: ) Host name of the client sent to a DHCP server. If not specified, client’s system identity will be used.
interface (string; Default: ) Interface on which DHCP client will be running.
script (script; Default: ) Execute script on status change. This parameter is available in v6.39rc33+ These are available variables that are accessible for the event script:
  • bound — 1 — lease is added/changed; 0 — lease is removed
  • server-address — server address
  • lease-address — lease address provided by server
  • interface — name of interface on which client is configured
  • gateway-address — gateway address provided by server
  • vendor-specific — stores value of option 43 received from DHCP server
  • lease-options — array of received options
use-peer-dns (yes | no; Default: yes) Whether to accept the DNS settings advertised by DHCP Server. (Will override the settings put in the submenu.
use-peer-ntp (yes | no; Default: yes) Whether to accept the settings advertised by DHCP Server. (Will override the settings put in the submenu)

Настройка роутера

Роутер на то и роутер чтобы управлять трафиком через firewall. Но мы не будем настраивать правила фильтрации в данной статье. Так же у нас не будет включена Hardware Offload т.к. мы используем лабораторный стенд и отсутствуют какие-либо чипы коммутации. Чипы коммутации отсутствуют на RouterBoard серии CCR и виртуалок CHR. Первым делом создадим bridge и добавим в него ether2-5.

На вкладке VLANs укажем сети.

Согласно схеме коммутации, у нас есть ПК в VLAN100 за Mikrotik2, Mikrotik4, Mikrotik5, в связи с этим указываем соответствующие Tagged интерфейсы. Добавляем бридж в бридж, это так сказать некий порт, между роутером и сетью который позволяет понимать трафик в определенном VLAN. Проделываем аналогично для 200-ой сети.

Далее настроим сеть управления, в которой будут коммутаторы и роутер, а также ПК VPC7.

«Почему так?» —спросите вы. Потому что данный тег нужно передавать на все коммутаторы, чтобы ими управлять, принимая его на устройствах.

Далее создадим VLAN интерфейсы и укажем на них адреса. В Interfaces создадим новый указав понятное название и VID. Обязательно указываем bridge1, т.к. повесить метку на физический интерфейс не получится, в связи с тем, что он находится в slave режиме (зависит от bridge).

Создаем по аналогии для меток 200 и 99.

Далее задаем адреса на интерфейсы:

  • VLAN100 – 192.168.100.1/24;
  • VLAN200 – 192.168.200.1/24;
  • VLAN99 – 192.168.99.1/24.

По аналогии добавляем адреса для сетей 200 и 99 выбрав соответствующее интерфейсы.

Все что мы сделали выше – подготовительные работы. Еще ничего не работает, метки не бегают, адреса фейковые. Обязательно все перепроверим и только после этого, открываем свойства bridge1 и включаем VLAN Filtering. Все начинает работать, до этой галочки – нет.

Сохраняем и перейдем к созданию DHCP серверов для Vlan сетей на нашем микротике Открываем IP – DHCP Server и жмем DHCP Setup.

Выбираем интерфейс, на котором будет работать служба DHCP.

На следующем шаге ничего не меняем.

Следом необходимо указать шлюз. В данном случае будет 192.168.100.1

Далее нам предлагают указать выдаваемый пул адресов.

DNS-сервер. В нашей инсталляции будет свой на каждый VLAN, т.е. 192.168.100.1. Если у вас уже есть DNS сервера, можете указать их.

И последнее – время аренды. Оставим по умолчанию.

После создания проверим, на верном ли интерфейсе у нас работает служба.

По аналогии создаем для 200 и 99.

На этом базовая настройка шлюза завершена.

Настройка DHCP сервера и шлюза по умолчанию для LAN

Теперь на нашем роутере нужно настроить DHCP сервер и дать ip адрес  интерфейсу, который будет шлюзом для внутренней сети. Для этого идем IP -> Addresses и добавляем его.

В поле адрес вводим ту подсеть, которая вам нужна и выбираем интерфейс bridge1, после этого наш MikroTik будет доступен по этому адресу чрез объединённые порты и через wifi (который мы еще настроим).

Дальше чтобы все устройства в сети могли получать адреса автоматически мы переходим в раздел IP-> DHCP и собственно настраиваем его через кнопку «DHCP Setup». Выбираем интерфейс, на котором он будет работать «это наш bridge1», жмем Next и оставляем пространства адресов по умолчанию. В моем случае это будет подсеть в которой находится сам роутер. То есть раздавать микротик будет адреса с 192.168.9.2-192.168.9.255.

После указываем адрес шлюза, который будут получат все подключенные устройства, так как это mikrotik оставляем значение по умолчанию.

В следующем окне перед нами встает выбор, раздавать ли весь диапазон адресов или его часть. По правильному лучше исключить первые 10 так как в будущем может появиться еще один роутер или коммутаторы которым желательно задать ip статикой. Но сейчас нам не принципиально, и мы оставляем как есть.

Наконец последним этапом указываем DNS. Если в вашей сети есть выделенный DNS сервер, то пишем его ip, если нет и вы настраиваете, например, для дома пишем ip самого роутера (в большинстве случаем так оно и будет).

Жмем далее, следующие значение не меняем. Все настройка DHCP сервера и шлюза по умолчанию на микротике закончена, переходим к следующему разделу.

Alerts

Sub-menu:

To find any rogue DHCP servers as soon as they appear in your network, DHCP Alert tool can be used. It will monitor the ethernet interface for all DHCP replies and check if this reply comes from a valid DHCP server. If a reply from an unknown DHCP server is detected, alert gets triggered:

 ip dhcp-server alert>/log print
00:34:23 dhcp,critical,error,warning,info,debug dhcp alert on Public:
    discovered unknown dhcp server, mac 00:02:29:60:36:E7, ip 10.5.8.236
 ip dhcp-server alert>

When the system alerts about a rogue DHCP server, it can execute a custom script.

As DHCP replies can be unicast, the ‘rogue dhcp detector’ may not receive any offer to other dhcp clients at all. To deal with this, the rogue dhcp detector acts as a dhcp client as well — it sends out dhcp discover requests once a minute

Properties

Property Description
alert-timeout (none | time; Default: none) Time after which alert will be forgotten. If after that time the same server is detected, new alert will be generated. If set to none timeout will never expire.
interface (string; Default: ) Interface, on which to run rogue DHCP server finder.
on-alert (string; Default: ) Script to run, when an unknown DHCP server is detected.
valid-server (string; Default: ) List of MAC addresses of valid DHCP servers.

Read only properties

Property Description
unknown-server (string) List of MAC addresses of detected unknown DHCP servers. Server is removed from this list after alert-timeout

Вход в настройки маршрутизатора

Откройте любой браузер, например, Internet Explorer и введите адрес 192.168.88.1

Внимание! В настройках браузера не должен быть указан proxy-сервер
Выполнить настройку роутера MikroTik можно разными способами:

Winbox — настройка с помощью специальной программы для ОС Windows;
Webfig — настройка через Web интерфейс;
Telnet — настройка по телнету.
Мы будем настраивать роутер Mikrotik с помощью программы Winbox, поэтому в окне браузера выбираем Winbox, сохраняем программу и запускаем.

Подключаемся к устройству с помощью сетевой утилиты WinBox:

  1. Нажимаем кнопку Neighbors для поиска с помощью широковещательных запросов устройств MikroTik в сети
  2. Выбираем в списке наш роутер
  3. Подключаемся по учетной записью admin с пустым паролем

Examples

Lease script example

Since RouterOS v6.39rc33, it is possible to execute a script when DHCP client obtains new lease or loses existing. This is an example script that automatically adds a default route with routing-mark=WAN1 and removes it when the lease expires or is removed.

/ip dhcp-client
add add-default-route=no dhcp-options=hostname,clientid disabled=no interface=ether2 script="{\r\
    \n    :local rmark \"WAN1\"\r\
    \n    :local count \r\
    \n    :if (\$bound=1) do={\r\
    \n        :if (\$count = 0) do={\r\
    \n            /ip route add gateway=\$\"gateway-address\" comment=\"WAN1\" routing-mark=\$rmark\r\
    \n        } else={\r\
    \n            :if (\$count = 1) do={\r\
    \n                :local test \r\
    \n                :if ( != \$\"gateway-address\") do={\r\
    \n                    /ip route set \$test gateway=\$\"gateway-address\"\r\
    \n                }\r\
    \n            } else={\r\
    \n                :error \"Multiple routes found\"\r\
    \n            }\r\
    \n        }\r\
    \n    } else={\r\
    \n        /ip route remove \r\
    \n    }\r\
    \n}\r\
    \n"

Resolve default gateway when ‘router’ (option3) is from different subnet

In some cases administrators tend to set ‘router’ option which cannot be resolved with offered IP’s subnet.
For example, DHCP server offers 192.168.88.100/24 to the client and option 3 is set to 172.16.1.1. This will result in unresolved default route:

 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0  DS  0.0.0.0/0                          172.16.1.1              1
 1 ADC  192.168.88.0/24    192.168.88.100  ether1 

To fix this we need to add /32 route to resolve the gateway over ether1, which can be done by running script below each time DHCP client gets an address

/system script add name="dhcpL" source={ /ip address add address=($"lease-address" . "/32") network=$"gateway-address" interface=$interface }

Now we can further extend the script, to check if address already exist, and remove the old one if changes are needed

/system script add name="dhcpL" source={ 
  /ip address {
    :local ipId 
    :if ($ipId != "") do={
      :if (!( = ($"lease-address" . "/32") && =$"gateway-address" )) do={
        remove $ipId;
        add address=($"lease-address" . "/32") network=$"gateway-address" \
          interface=$interface comment="dhcpL address"
      }
    } else={
      add address=($"lease-address" . "/32") network=$"gateway-address" \
        interface=$interface comment="dhcpL address"
    }
  }
}

Quick setup example

This simple example demonstrates how to enable dhcp client to receive IPv6 prefix and add it to the pool.

/ipv6 dhcp-client add request=prefix pool-name=test-ipv6 pool-prefix-length=64 interface=ether13 

Detailed print should show status of the client and we can verify if prefix is received

 /ipv6 dhcp-client> print detail 
Flags: D - dynamic, X - disabled, I - invalid
 0 interface=bypass pool-name="test-ipv6" pool-prefix-length=64 status=bound 
prefix=2001:db8:7501:ff04::/62 expires-after=2d23h11m53s request=prefix

Notice that server gave us prefix 2a02:610:7501:ff04::/62 . And it should be also added to ipv6 pools

 /ipv6 pool> print 
Flags: D - dynamic 
# NAME PREFIX REQUEST PREFIX-LENGTH
0 D test-ipv6 2001:db8:7501:ff04::/62 prefix 64

It works! Now you can use this pool, for example, for pppoe clients.

Как настроить DHCP Relay на Mikrotik

Итак, чтобы разобраться как настраивать DHCP Relay на Mikrotik я поднял для большего и наглядного понимания стенд под Virtualbox основной своей системы Ubuntu Trusty Desktop ноутбука Lenovo E555 (16Gb-оперативной памяти это позволяют).

Развернута VM с осью Windows Server 2016 (Version 10.0.14393) с ролями AD,DNS,DHCP и в настройках данной виртуальной системы указано, что: Машина — Настроить — Сеть — Адаптер №1 — Внутренняя сеть — Имя: intnet

Далее в сервисе DHCP создана область той сети которая будет находиться за шлюзом, в моем случае это 192.168.3.100-192.168.3.200, ниже скриншот для наглядного представления:

MikrotikMikrotikVirtualbox

  • Первый (Адаптер №1) — Внутренняя сеть — Имя: innet → смотрит в сеть где расположен домен контроллер и ролью DHCP в которой он указан, как шлюз.
  • Второй (Адаптер №2) — Внутренняя сеть — Имя: innet1 → смотрит в сеть которая уже находится за Mikrotik, т. к. сеть 192.168.3.0/24 собственно на которую я хочу прокинуть DHCP сервис от Windows Server 2016На Mikrotik (v6.41.2 on x86) обозначены статические IP адреса, где зеленым цветом обозначен интерфейс отвечающий за сеть после Mikrotik.

NAT

После чего настраивается функция прокладывания запросов от DHCP сервиса во внутреннюю сеть за интерфейсом ether2: winbox — ip&user&pass — IP — DHCP Relay — Add вкладка General:

  • Name: relay1
  • Interface: ether2
  • DHCP Server: 192.168.2.2 → это Windows система с ролями DNS,DHCP,AD
  • Local Address: 192.168.3.1 → это адрес Mikrotik интерфейс ether2 который смотрит в сеть за Mikrotikом
  • Add Relay Info: отмечаю галочкой
  • Relay Info Remote ID: relay1после нажимаю Apply и Ok. А вот сейчас развернута еще одна VM с осью Windows 7 x64 Pro (Version 6.1.7601) где настройки сети виртуальной машины: Машина — Настройки — Сеть — Адаптер №2 — Внутренняя сеть — intnet1, полученные настройки от Mikrotik идут прямиком от DHCP сервиса за ним из второй сети:

DHCPWindows Server 2016Win + R → control.exe — Администрирование — DHCP — DHCP — srv-dc.polygon.local — IPv4 — Область relay — Адресованные адреса

D-Link DFL-860EОлло Александр aka ekzorchik.

источник

Настройка локальной сети

Первый порт у нас подключен к провайдеру и в нашем случае остается еще 3 локальных порта плюс модуль WiFi (в других моделях локальных портов может быть больше, как и модулей WiFi), сейчас они все как бы висят в воздухе и никуда не подключены, никакой трафик никуда не ходит, а нам нужно чтоб ходил, для этого объединим локальные порты и создадим сетевой мост, который объединит локальные порты и WiFi. Все порты и модуль WiFi Вы можете переименовать как Вам удобно, я этого делать не буду. Объединять порты в Микротик можно двумя способами, аппаратным (но только те которые относятся к одному чипу) и программным можно объединить любые. Аппаратное объединение очевидно быстрее, им объединим локальные порты а затем создадим программный сетевой мост между ними и WiFi-интерфейсом. Один из локальных портов, удобнее всего последний выбираем главным (master), остальные подчиняем ему, делается это просто к примеру у нас последний 4-й порт, он будет главным, его настройки не меняются, заходим в третий и выбираем для него мастер-портом четвертый:

Повторяем операцию с оставшимися свободными портами и должно получиться вот так:

4-й порт мастер, хоть это нигде и не указано, 2-й и 3-й имеют пометку S — Slave, подчиненный в нашем случае.

Команды для консоли:

/interface ethernet set master-port=ether4
/interface ethernet set master-port=ether4

Для остальных портов команды аналогичные, нужно только сменить имена портов на свои. Теперь нужно добавить к нашей локальной сети WiFi интерфейс, для этого создадим Bridge (мост).

Сперва создадим сам мост, а затем добавим в него нужные порты:Bridge > + > Name:bridge1Bridge > Ports > + > Interface: ether4; Bridge: bridge1Bridge > Ports > + > Interface: wlan1; Bridge: bridge1

Или можно выполнить в консоли:/interface bridge add name=bridge1/interface bridge port add interface=ether4 bridge=bridge1 /interface bridge port add interface=wlan1 bridge=bridge1

Заметьте что в bridge1 мы добавляем только мастер-порт, теперь bridge1 это интерфейс который смотрит в локальную сеть, его и будем использовать в дальнейшем для настройки. Для того чтоб работала локальная сеть на  bridge1 — нужно добавить IP-адрес, а чтоб IP-адреса раздавались автоматически нужно на нем же поднять DHCP-сервер.

Добавляем ip на bridge1: IP > Addresses > + > Address: 192.168.88.1/24; Interface: bridge1Или в консоли:/ip address add address=192.168.88.1/24 interface=bridge1

Далее нужно настроить раздачу IP-адресов для всех устройств подключенных к нашей локальной сети, как проводом так и по WiFi, сделать это можно двумя способами, с помощью мастера и вручную. Ниже показаны оба варианта, первый с помощью мастера, заходим в меню IP > DHCP Server > DHCP Setup и далее заполняем нужные поля и жмем Next. 

Все скрины я приводить не буду, статья и так длинная, мастер спросить на каком интерфейсе поднимать сервер в нашем случае это bridge1, затем адрес сети — 192.168.88.0/24, затем адрес шлюза — 192.168.88.1, затем размер пула в виде начального и конечного адреса — 192.168.88.100-192.168.88.254, затем нужно указать DNS сервера, я обычно использую гугловские 8.8.8.8 и 8.8.4.4, затем указываем время аренды, значение по умолчанию 00:10:00 — 10 минут, можно изменить на свое, можно оставить так, и на этом настройка закончена.
Все тоже самое можно настроить и вручную:
Создаем пул из которого будем выдавать адреса, в примере на 100 адресов, вы можете сделать его больше или меньше: IP > Pool > + > Name: pool1; Addresses:192.168.88.100-192.168.88.200
Или в консоли:/ip pool add name=pool1 address=192.168.88.100-192.168.88.200Теперь можно добавлять DHCP сервер на интерфейс bridge1 IP > DHCP Server > + , Name = dhcp1, Interface = bridge1, Address Pool = pool, остальные настройки не трогаем, Lease Time  у меня стоит полчаса, в домашней сети можно ставить 8 часов и больше:Теперь переходим на вкладку Network, там нужно указать какие параметры будет отдавать наш сервер своим клиентам, необходимый минимум для работы сети Address, Gateway, Netmask — ее можно указать отдельно в поле или дописать к IP-адресу через / и DNS:
Или в консоли:/ip dhcp-server add name=dhcp1 interface=bridge1 lease-time=00:30:00 address-pool=pool1/ip dhcp-server network add address=192.168.88.0/24 dns-server=8.8.8.8,8.8.4.4 gateway=192.168.88.1 netmask=24

Оцените статью
Рейтинг автора
5
Материал подготовил
Андрей Измаилов
Наш эксперт
Написано статей
116
Добавить комментарий